System Running Smoothly

All systems are operational.

24H Global Uptime
98.44%

Overall Uptime

97.00%
Last 7 days
99.18%
Last 30 days
99.54%
Last 90 days
99.77%
Last 6 months

Monitored Services

Past 24 Hours
UP Website
100.0%
UP Client Area
87.54%
UP NLX VPS Hypervisor
100.0%
UP NL01 Web Host
100.0%
UP NL01 Web Panel
100.0%
UP NL02 VPS Control Server
100.0%
UP VPS Panel
100.0%
UP NL04 Storage Host
100.0%

Incidents (last 90 days)

45 incidents
May 17, 2026

Uptime Monitor - Client Area

- - 2 hours 59 minutes
Resolved

May 16, 2026

Uptime Monitor - Client Area

- - 6 minutes 15 seconds
Resolved

May 14, 2026

Instance Status - NL01 Web Host

- - 11 hours 23 minutes
Resolved

eXact Digital - All rights reserved